Mailinglist Archive: opensuse-buildservice (227 mails)

< Previous Next >
[opensuse-buildservice] Qt database bindings broken again
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Mon, 29 Jan 2007 12:33:21 +0100
  • Message-id: <200701291233.22085.hpj@xxxxxxxxx>
Hi Stephan, hi *,

I'm using the openSUSE KDE packages for quite some time now (but because
dependence on some customer installations still on 9.3..), if only it
wouldn't break the Qt database bindings more often than not :-(.

While I do not understand the rationale behind the "outsourcing" of that
stuff packetwise, and building it separately, I vote for some build trigger
that ensures the rebuild of qt3-extensions in case qt3 is built.

These are the current offenders:
qt3-3.3.7-29.1
qt3-extensions-3.3.7-30.1
qt3-devel-tools-3.3.7-30.1
qt3-mysql-3.3.7-30.1
qt3-devel-3.3.7-29.1
qt3-sqlite-3.3.7-30.1
qt3-unixODBC-3.3.7-30.1
qt3-postgresql-3.3.7-30.1

Attached is a minimal test to list the available database bindings.

Thanks,
Pete
SOURCES = main.cpp
#include <qapplication.h>
#include <qsqldatabase.h>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{
QApplication app(argc, argv);
QStringList list = QSqlDatabase::drivers();
QStringList::Iterator it = list.begin();
cout << "Available Qt database drivers: ";
while( it != list.end() ) {
cout << *it << " ";
++it;
}
cout << endl;
return 0;
}
< Previous Next >
Follow Ups