Mailinglist Archive: opensuse-buildservice (253 mails)

< Previous Next >
Re: [opensuse-buildservice] xUbuntu_6.06: expansion error: have choice for awk needed by base-files: mawk gawk
  • From: Thomas Anders <thomas.anders@xxxxxxxxxxxxx>
  • Date: Thu, 23 Nov 2006 11:47:41 +0100
  • Message-id: <45657C4D.5070709@xxxxxxxxxxxxx>
Marian Jancar wrote:
> Adrian Schröter wrote:
>> Am Thursday 23 November 2006 00:04 schrieb Thomas Anders:
>>> Building on xUbuntu_6.06 fails for me with:
>>>
>>> expansion error: have choice for awk needed by base-files: mawk gawk
>>>
>>> Is this a problem with my .dsc (Project net-snmp, package
>>> net-snmp-main-snapshot) or a BS bug?
>> it is not a bug at least. You can either reqeuest mawk or gawk directly,
>> instead of awk in your .dsc file.
>
> Maybe the error message could state more clearly.

I'm not convinced there's anything bad with requiring just "awk" in the
package, so I think the default xUbuntu setup should prefer one choice
itself.


+Thomas

--
Thomas Anders (thomas.anders at blue-cable.de)
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >