Mailinglist Archive: opensuse-buildservice (253 mails)

< Previous Next >
Re: [opensuse-buildservice] linking libqt4 and dbus
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Thu, 16 Nov 2006 14:37:43 +0100
  • Message-id: <200611161437.44481.adrian@xxxxxxx>
Am Thursday 16 November 2006 13:28 schrieb Pavel Nemec:
> Hi,
> i need build some packages (zhu3d and Reveal) which need libqt4.
> Darix advice me not to link package directly, because they will be builded
> again in my project. And use osc editmeta to add sources.
>
> This is osc editmeta home:pnemec
> <project name="home:pnemec">
> <title>pnemec's Home Project</title>
> <description>packages for my personal use</description>
> <person userid="pnemec" role="maintainer"/>
> <repository name="SUSE_Factory">
> <path repository="standard" project="SUSE:Factory"/>
> <arch>i586</arch>
> <arch>x86_64</arch>
> </repository>
> <repository name="SUSE_Linux_10.0">
> <path repository="standard" project="SUSE:SL-10.0"/>
> <path repository="SUSE_Linux_10.0" project="KDE:KDE4"/>
> <path repository="SUSE_Linux_10.0" project="DBUS"/>
> <arch>i586</arch>
> <arch>x86_64</arch>
> </repository>

In this way the dbus-1 package from 10.0 gets selected, but this one does not
provide .so.3. It should work with that:

<repository name="SUSE_Linux_10.0">
<path repository="SUSE_Linux_10.0" project="KDE:KDE4"/>
<path repository="standard" project="SUSE:SL-10.0"/>
<arch>i586</arch>
<arch>x86_64</arch>
</repository>


> <repository name="SUSE_Linux_10.1">
> <path repository="standard" project="SUSE:SL-10.1"/>
> <path repository="SUSE_Linux_10.0" project="KDE:KDE4"/>
> <path repository="SUSE_Linux_10.1" project="DBUS"/>
> <arch>i586</arch>
> <arch>x86_64</arch>
> </repository>
> </project>
>
> But building still faild with complain about
> SUSE_Linux_10.0
> x86_64 expansion error nothing provides libdbus-1.so.3()(64bit) needed
> by i586 expansion error nothing provides libdbus-1.so.3 needed by
> libqt4-devel
> SUSE_Linux_10.1
> x86_64 expansion error nothing provides libqt4-devel,nothing provides
> libqt4-x11,nothing provides libqt4-sql,nothing provides libqt4-qt3support
> i586 expansion error nothing provides libqt4-devel,nothing provides
> libqt4-x11,nothing provides libqt4-sql,nothing provides libqt4-qt3support
>
> Where i am doing mystake?

--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References