Mailinglist Archive: opensuse-buildservice (252 mails)

< Previous Next >
Re: [opensuse-buildservice] Debian expansion errors
  • From: Michael Schroeder <mls@xxxxxxx>
  • Date: Tue, 5 Sep 2006 16:03:52 +0200
  • Message-id: <20060905140351.GB16171@xxxxxxx>
On Tue, Sep 05, 2006 at 10:49:20AM +0200, Thomas Anders wrote:
> My debian/control file contains a line such as
>
> Build-Depends: libkvm-dev [kfreebsd-i386 kfreebsd-amd64]
>
> which doesn't seem to be properly processed by the Build Service,
> because it yields
>
> expansion error: nothing provides libkvm-dev
>
> on Debian_Etch i586. Am I missing something here or do we need better
> parsing?

Better parsing. The build service currently ignores all architecture
selectors. Shouldn't be hard to add, though, I just need to copy
some code from the spec file parser...

Cheers,
Michael.

--
Michael Schroeder mls@xxxxxxx
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References