Mailinglist Archive: opensuse-buildservice (156 mails)

< Previous Next >
Re: [opensuse-buildservice] Xgl + Xinerama for Xorg 7 and Buildrequire problem
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 8 Aug 2006 08:34:21 +0200
  • Message-id: <200608080834.21837.adrian@xxxxxxx>
Am Tuesday 08 August 2006 08:10 schrieb Jigish Gohil:
> Hi all
>
> I am trying to build Xgl with Xinerama patch. I have been successful
> in creating a package built against Xorg7 repository (standard/Xorg7).
> The package is available here:
>
> http://software.opensuse.org/download/Compiz-Quinn/standard/i586/
>
> However building for 10.1 and Factory fails as I have to remove
> xorg-x11-compat70-devel from Buildrequires.
>
> How do I specify buildrequires per repository? I dont know what goes
> in place of ifrepository.
>
> something like
>
> %ifrepository standard
> Buildrequires: xyz
> %endif
> %ifrepository 10.1
> Buildrequires: xorg-x11-compat70-devel
> %endif

%if %suse_version = 1001
Buildrequires: xorg-x11-compat70-devel
%else
Buildrequires: xyz
%endif

?
--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx


< Previous Next >
References