Mailinglist Archive: opensuse-buildservice (110 mails)

< Previous Next >
[opensuse-buildservice] Re: opensuse-buildservice: package mapping for dbus on fedora ?
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Fri, 28 Jul 2006 11:45:06 +0200
  • Message-id: <200607281145.06757.adrian@xxxxxxx>

CC'ing the list ...

Am Friday 28 July 2006 01:15 schrieb Norm Paxton:
> Adrian,
>
> From the opensuse-buildservice, while you were out:
> Can you help me with this? (I'll be happy to provide more info, if
> necessary)
>
> -Norm Paxton
> ***************************************************************
> normp: darix: appears that adrianS is out of office today (hasn't been
> online for a while). Is there somebody else that could help us resolve
> the package mapping question from yesterday about dbus on fedora?
>
> judas_iscariote: normp: what's the issue eh ? ;)
>
> normp: I have a project that requires hwinfo. On SuSE, no problem -
> hwinfo is fine there. I have to include (build) hwinfo in my project,
> for fedora. hwinfo has a Requires (but not BuldRequires) on dbus-1.
> fedora defaults with dbus-0.
>
> normp: KDE/KDE4 has a dbus-1 package on fedora. I linked that project.
>
>
> normp: At my project (omc-base, which requires hwinfo) build prep, it
> installs dbus-1 (as expected) but immediately after, tries to install
> dbus-0, causing conflicts.
>
> normp: Suggestion was that this is likely a package-mapping problems
> with dbus on fedora.
>
> normp: If I add dbus-1 as a 'BuildRequires' on hwinfo, I get identical
> problem building hwinfo, if that helps narrow it down?

The problem is that some package within the BuildRequires requires dbus-0.
This is nothing what can be fixed via mappings, it is a packaging issue of
dbus-1 in first place.

Either dbus-1 packages for Fedora needs to be able to coexist with dbus-0
packages or it must be possible to setup a system with dbus-1 only.

This is not an issue of the build service, it is a coding issue in first
place. If dbus-1 is incompatible with dbus-0, but can't coexist it is problem
within dbus in first place.

bye
adrian

--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx


---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice-unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice-help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages