Mailinglist Archive: opensuse-buildservice (113 mails)

< Previous Next >
Re: java-1_5_0-sun-devel dependency
  • From: Peter Nixon <listuser@xxxxxxxxxxxxxx>
  • Date: Tue, 23 May 2006 11:21:49 +0300
  • Message-id: <200605231121.55561.listuser@xxxxxxxxxxxxxx>
On Tue 23 May 2006 11:14, Daniel Bornkessel wrote:
> On Tuesday 23 May 2006 09:24, Peter Nixon wrote:
> > On Thu 18 May 2006 12:21, Adrian Schröter wrote:
> > > Am Wednesday 17 May 2006 19:21 schrieb Peter Nixon:
> > > > How can packages that require java-1_5_0-sun-devel and other java
> > > > packages be built on the build service which appears to only include
> > > > OSS packages?
> > >
> > > The current plan is to create a "non-oss" project which provides java
> > > and graphviz ...
> > >
> > > You are the third one today asking for this, I will try to have a look
> > > in this today ;)
> >
> > Any news on this yet?
> >
> > Cheers
>
> Hi Peter.
> Does it really need > 1.4.2? I will submit 1.4.2 gcj compat packages that
> use the ecj (Eclipse Java Compiler) soon.
> For a complete 1.5.0 devel package there will be a package, which however
> will be very experimental as it will use GNU Classpath "generics" release,
> which is not (yet) feature complete.
> However, including a commercial Java >= 1.5.0 is probably a good idea until
> the OSS packages > 1.4.2 still need some time.
> Regards,

Hi Daniel

I actually have two packages I wish to make work on the SUSE build system. The
first one is sipXpbx which says it requires java 1.5.0. You can see more
about it at:

http://sipx-wiki.calivia.com/index.php/Dependencies
http://sipx-wiki.calivia.com/index.php/SUSE_Linux_10.1:_Build_Environment_for_sipX

The second one is OpenNMS which currently requires java 1.4.2 and Tomcat 4
(NOT Tomcat 5!!)

I have not tried to anything but Sun java with both these packages

--

Peter Nixon
http://www.peternixon.net/
PGP Key: http://www.peternixon.net/public.asc
< Previous Next >