Mailinglist Archive: opensuse-bugs (3803 mails)

< Previous Next >
[Bug 813641] New: NFSv4 idmapper broken: rpc.idmapd: nss_getpwnam: name '1000' does not map into domain 'bla.test'
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 5 Apr 2013 07:08:56 +0000
  • Message-id: <bug-813641-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=813641

https://bugzilla.novell.com/show_bug.cgi?id=813641#c0


Summary: NFSv4 idmapper broken: rpc.idmapd: nss_getpwnam: name
'1000' does not map into domain 'bla.test'
Classification: openSUSE
Product: openSUSE 11.4
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.4
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: gleixner@xxxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101
Firefox/19.0

I have a NFSv4 Server using Opensuse 12.2 and two NFSv4 Clients, one Opensuse
12.2 and another 11.4 (evergreen). All 3 machines have kerberos/ldap for
authentication and can resolve ldap entries correctly using
getent passwd 1000
or
getent passwd flo

The clients use the same automounter maps (via ldap) to mount homes. The maps
force the clients to use NFSv4. All have exactly the same /etc/idmapd.conf with
the domain set to "bla.test".

The opensuse 12.2 NFS client gets the correct ownership of the mounted homes,
while the opensuse 11.4 client gets nobody/nobody.

Running rpc.idmapd -f i get:

rpc.idmapd: libnfsidmap: using domain: bla.test

rpc.idmapd: libnfsidmap: loaded plugin /usr/lib64/libnfsidmap/nsswitch.so for
method nsswitch

rpc.idmapd: Expiration time is 600 seconds.
rpc.idmapd: nfsdopenone: Opening /proc/net/rpc/nfs4.nametoid/channel failed:
errno 2 (No such file or directory)
rpc.idmapd: New client: 4c2
rpc.idmapd: Opened /var/lib/nfs/rpc_pipefs/nfs/clnt4c2/idmap
rpc.idmapd: New client: 4c3
rpc.idmapd: nfs4_name_to_uid: calling nsswitch->name_to_uid

rpc.idmapd: nss_getpwnam: name '0' domain 'bla.test': resulting localname
'(null)'

rpc.idmapd: nss_getpwnam: name '0' does not map into domain 'bla.test'

rpc.idmapd: nfs4_name_to_uid: nsswitch->name_to_uid returned -22

rpc.idmapd: nfs4_name_to_uid: final return value is -22

rpc.idmapd: Client 4c2: (user) name "0" -> id "65534"
rpc.idmapd: nfs4_name_to_gid: calling nsswitch->name_to_gid

rpc.idmapd: nfs4_name_to_gid: nsswitch->name_to_gid returned -22

rpc.idmapd: nfs4_name_to_gid: final return value is -22

rpc.idmapd: Client 4c2: (group) name "0" -> id "65533"
rpc.idmapd: New client: 4c4
rpc.idmapd: nfs4_name_to_uid: calling nsswitch->name_to_uid

rpc.idmapd: nss_getpwnam: name '1000' domain 'bla.test': resulting localname
'(null)'

rpc.idmapd: nss_getpwnam: name '1000' does not map into domain 'bla.test'

rpc.idmapd: nfs4_name_to_uid: nsswitch->name_to_uid returned -22

rpc.idmapd: nfs4_name_to_uid: final return value is -22

rpc.idmapd: Client 4c2: (user) name "1000" -> id "65534"
rpc.idmapd: nfs4_name_to_gid: calling nsswitch->name_to_gid

rpc.idmapd: nfs4_name_to_gid: nsswitch->name_to_gid returned -22

rpc.idmapd: nfs4_name_to_gid: final return value is -22

rpc.idmapd: Client 4c2: (group) name "1000" -> id "65533"


I guess nfsidmap package is buggy?



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages