Mailinglist Archive: opensuse-bugs (4069 mails)

< Previous Next >
[Bug 709561] New: system hangs on ping -R through "bridge over vlan over bond" interface
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 1 Aug 2011 12:56:36 +0000
  • Message-id: <bug-709561-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=709561

https://bugzilla.novell.com/show_bug.cgi?id=709561#c0


Summary: system hangs on ping -R through "bridge over vlan over
bond" interface
Classification: openSUSE
Product: openSUSE 11.4
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.4
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: ccrssaa@xxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; ru; rv:1.9.1.19)
Gecko/20110420 SUSE/2.0.14-0.2.1 SeaMonkey/2.0.14

Xeon E5620, MB with two Intel 82576 NICs (Supermicro x8DTH-6F actually)
clean openSUSE 11.4 installation, kernel 2.6.37.6-0.5 (xen, default)
Both NICs are connected to switch
Ports are in trunk mode with tagged membership for vlan 1, LACP enabled

NICs (eth0, eth1) are bonded (bond0)
vlan over bond (bond0.1) created
bridge created (br0) and vlan added to the bridge
system hangs on ping -R through the bridge


Reproducible: Always

Steps to Reproduce:
1. modprobe igb
2. modprobe bonding mode=802.3ad miimon=100
3. ifconfig bond0 up
4. ifenslave bond0 eth0
5. ifenslave bond0 eth1
6. modprobe 8021q
7. vconfig add bond0 1
8. ifconfig bond0.1 192.168.1.11 netmask 255.255.255.0 up
9. ping 192.168.1.1 - get response, press ^C
10. ping -R 192.168.1.1 - get response, press ^C
11. ifconfig bond0.1 0.0.0.0
12. brctl addbr br0
13. brctl addif br0 bond0.1
14. ifconfig br0 192.168.1.11 netmask 255.255.255.0 up
15. ping 192.168.1.1, get response, press ^C
16. ping -R 192.168.1.1 - system crashes


Actual Results:
system hangs

Expected Results:
pong

same problem for -default and -xen kernels
same problem for other vlan ids (!= 1)
TCP works without problems (at least ssh)

comments/patches are welcome

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >