Mailinglist Archive: opensuse-bugs (6932 mails)

< Previous Next >
[Bug 642289] System does not boot correctly with sysvinit-tools-2.88-15.1.x86_64.rpm or newer (blogd issue)

https://bugzilla.novell.com/show_bug.cgi?id=642289

https://bugzilla.novell.com/show_bug.cgi?id=642289#c13


Dr. Werner Fink <werner@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |gregkh@xxxxxxxxxx,
| |kasievers@xxxxxxxxxx

--- Comment #13 from Dr. Werner Fink <werner@xxxxxxxxxx> 2011-03-21 11:44:20
UTC ---
I've here also a report from our build service ... due to the
start of udev service something happens with /dev/console which
cause blogs to loose its master tty side on the current system
console (aka /dev/console) ... it seems that /dev/console is
remapped by the kernel from /dev/pts/0 back to /dev/tty1.

This could be caused by loading e.g. KMS modules due the rules
of the udev service. This seems to be very racy as older (and
much slower) blogd does run not into this problem or if
RUN_PARALLEL if set to "no" or if an older kernel is booted.

Beside this due bug #677435 the new blogd close the initial
file descriptor 0 on /dev/console after the ioctl TIOCCONS
to use explicit the open master side of the /dev/pts/0
as file descriptor 0. This was necessary with kernel 2.3.37.

Strange

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >