Mailinglist Archive: opensuse-bugs (6934 mails)

< Previous Next >
[Bug 681146] New: Permissions of SCSI-scanners are not set as required. Users cannot scan, only root can do that.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 21 Mar 2011 05:24:40 +0000
  • Message-id: <bug-681146-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=681146

https://bugzilla.novell.com/show_bug.cgi?id=681146#c0


Summary: Permissions of SCSI-scanners are not set as required.
Users cannot scan, only root can do that.
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: dieter.jurzitza@xxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux i686; rv:2.0b12) Gecko/20110222
Firefox/4.0b12

After installation of openSUSE I cannot scan any more as user. This is
obviously due to a permission issue.
When runnding yast configuration dialog, the scanner is detected flawlessly and
configured (mustek), the device is found (/dev/sg3).
However, the permissions are not set in such away that users may scan - only
root can do. Manually adjusting the device permissions fixes the issue - chmod
0666 /dev/sg3 - but this is not how it should be.

Reproducible: Always

Steps to Reproduce:
1. Install the scanner and configure it
2.
3.
Actual Results:
No scanning as user

Expected Results:
Scanning as user

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >