Mailinglist Archive: opensuse-bugs (5934 mails)

< Previous Next >
[Bug 674287] New: Gstreamer fails to use v4l2 webcam
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 23 Feb 2011 10:17:09 +0000
  • Message-id: <bug-674287-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=674287

https://bugzilla.novell.com/show_bug.cgi?id=674287#c0


Summary: Gstreamer fails to use v4l2 webcam
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: i586
OS/Version: SuSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: GNOME
AssignedTo: bnc-team-gnome@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: michael_denker@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13)
Gecko/20101206 Ubuntu/10.04 (lucid) Firefox/3.6.13

I have a Logitech Notebook Deluxe webcam. Webcam worked flawless under openSUSE
11.3.


After Upgrade (not fresh install) to 11.4RC1, the systems level driver of the
camera still seems to work:
*Start Ekiga
*Select in Properties->Video: Input device: Camera PTLIB/V4L2
*Ekiga shows the webcam video when clicking on 'Display images from your camera
device'.


However, using gstreamer as driver does not work:
*Start Ekiga
*Select in Properties->Video: Input device: Camera Gstreamer/V4L2
*Ekiga does not show the webcam video when clicking on 'Display images from
your camera device'.


Pressing the 'Test' Button in gstreamer-properties, Video Tab, selecting the
V4L2 camera, yields a dialogue box:
'Video for Linux 2 (v4l2): Could not negotiate format'.
Console output in response to clicking the 'Test' button is:
'Could not negotiate format [gstbasesrc.c(2778): gst_base_src_start ():
/GstPipeline:pipeline0/GstV4l2Src:v4l2src1:
Check your filtered caps, if any]'

Likewise, programs such as cheese or skype cannot communicate with the webcam
(which both worked in 11.3).

Testing with a different (newer) Logitech camera (also v4l2) did not show this
effect and worked perfectly.

Therefore, I suspect it seems to be an issue both hardware and gstreamer
specific.


Reproducible: Always

Steps to Reproduce:
1.See steps outlined above
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages