Mailinglist Archive: opensuse-bugs (4845 mails)

< Previous Next >
[Bug 654729] [SMBTA] Fix the curses detection in the smbtatools build
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 Nov 2010 18:39:15 +0000
  • Message-id: <20101122183915.CC6CB245520@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=654729

https://bugzilla.novell.com/show_bug.cgi?id=654729#c8


Holger Hetterich <hhetter@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|ASSIGNED |NEEDINFO
InfoProvider| |bjl@xxxxxxxxx

--- Comment #8 from Holger Hetterich <hhetter@xxxxxxxxxx> 2010-11-22 18:39:14
UTC ---
Ok, that's the same problem with both builds. Let us try a fix on smbtatools.
Bruce, please check if it helps to add this line into CMakeLists.txt of
smbtatools :

INCLUDE_DIRECTORIES( ${SQLITE3_INCLUDEDIR} ${TALLOC_INCLUDE_DIR}
${LIBSMBCLIENT_INCLUDE_DIRS} )

This line shall add the include directories of found development components to
the build. It just works on my system because all of the software components
are in system include search paths.

Add the line just after all the component checks, before the build lists, in
smbtatools CMakeLists.txt it should be here:
#
# check for pthreads
#
FIND_PACKAGE(Threads)
if (NOT CMAKE_USE_PTHREADS_INIT)
MESSAGE( FATAL_ERROR "ERROR: you will need pthread development files
installed.")
ENDIF()

INCLUDE_DIRECTORIES( ${SQLITE3_INCLUDEDIR} ${TALLOC_INCLUDE_DIR}
${LIBSMBCLIENT_INCLUDE_DIRS} )

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References