Mailinglist Archive: opensuse-bugs (4661 mails)

< Previous Next >
[Bug 638924] New: Policy-kit reports unregistered authentication agent on X server restart and hangs
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 13 Sep 2010 14:22:07 +0000
  • Message-id: <bug-638924-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=638924

https://bugzilla.novell.com/show_bug.cgi?id=638924#c0


Summary: Policy-kit reports unregistered authentication agent
on X server restart and hangs
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: i586
OS/Version: openSUSE 11.3
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Security
AssignedTo: security-team@xxxxxxx
ReportedBy: vankan@xxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=389181)
--> (http://bugzilla.novell.com/attachment.cgi?id=389181)
Last 100 lines of /var/log/messages before the crash

User-Agent: Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.9.2.8)
Gecko/20100723 SUSE/3.6.8-0.1.1 Firefox/3.6.8

If I restart the X server (for instance after a logout or a session change) the
polkitd reports

Sep 13 15:46:36 pavilion102 polkitd(authority=local): Unregistered
Authentication Agent for session /org/freedesktop/ConsoleKit/Session1 (system
bus name :1.27, object path /org/kde/PolicyKit1/AuthenticationAgent, locale
nl_NL@euro) (disconnected from bus)

in /var/log/messages and the graphics terminal hangs (totally black screen).
The text terminals f1-f6 are still usable.

If I reboot (so the X server is started for the first time) the authentication
process proceeds without hiccups:
Sep 13 13:28:39 pavilion102 polkitd(authority=local): Registered Authentication
Agent for session /org/freedesktop/ConsoleKit/Session1 (system bus name :1.27
[/usr/lib/kde4/libexec/polkit-kde-authentication-agent-1], object path
/org/kde/PolicyKit1/AuthenticationAgent, locale nl_NL@euro)

Probably some misconfiguration of PolicyKit. Upgraded from 11.0 to 11.3 and use
KDE 4.4.4 Use kdm as login manager

Regards, Jos.


Reproducible: Always

Steps to Reproduce:
1.Login into graphical login screen
2.Logout
3.
Actual Results:
screen goes black and does not respond

Expected Results:
Come back with the login screen again.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >