Mailinglist Archive: opensuse-bugs (4669 mails)

< Previous Next >
[Bug 627504] zypper 1.4.5 ignores allowVendorChange
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 1 Sep 2010 10:20:05 +0000
  • Message-id: <20100901102006.016CE245523@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=627504

https://bugzilla.novell.com/show_bug.cgi?id=627504#c7


--- Comment #7 from Javier Llorente <javier@xxxxxxxxxxxx> 2010-09-01 10:20:04
UTC ---
(In reply to comment #5)
c#4: there are only the two possibilities: either put a vendor file for that
repo's vendor to /etc/zypp/vendors.d just like you did above, or ignore vendor
checking completely by setting the solver.allowVendorChange = true (which is
probably not a good idea as a default).

As for the previous releases, IIRC the vendor locking works like this since
the
introduction of sat solver in 11.0. Are you sure it worked in 11.x? If you
feel
there's a bug or we should improve something, yes, please open a new bug
report.

I mean we could make kupdateapplet shows upgrades in past openSUSE releases
(since 10.3?). I don't think it's related to the introduction of vendor
locking.
OK, opened a new bug report #636172

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >