Mailinglist Archive: opensuse-bugs (6177 mails)

< Previous Next >
[Bug 615649] intel [945G/965GM/G45] System freezes in GNOME/KDE (sometimes)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 28 Jul 2010 17:39:11 +0000
  • Message-id: <20100728173911.A2C6D245520@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=615649

http://bugzilla.novell.com/show_bug.cgi?id=615649#c45


--- Comment #45 from Alex Poddubny <maelstrom2001@xxxxxxxxx> 2010-07-28
17:39:09 UTC ---
I think that the problem is completely solved. Rebuild from scratch and install
xf86-video-intel 2.10.0 release from http://intellinuxgraphics.org/2009Q4.html
Before building drivers you'll need to install xorg-x11-server-sdk,
MesaGLw-devel with all dependencies and gcc of course ;)
Complete guide you can find here: http://intellinuxgraphics.org/install.html
Make in easier:
1. Download and unpack xf86-video-intel-2.10.0.tar.bz2
2. Enter driver directory as root and execute ./configure
3. make install
4. Copy /usr/local/lib/xorg/modules/drivers/intel_drv.so to
/usr/lib/xorg/modules/drivers with overwriting
5. Do not forget to comment with # Driver "intellegacy" in
/etc/X11/xorg.conf.d/50-device.conf or simply delete this string
6. Restart X with Ctrl+Alt+Backspace (twice) or reboot
Now check the /var/log/Xorg.0.log:
[ ] (II) LoadModule: "intel"
[ ] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ ] (II) Module intel: vendor="X.Org Foundation"
[ ] compiled for 1.8.0, module version = 2.10.0
[ ] Module class: X.Org Video Driver
[ ] ABI class: X.Org Video Driver, version 7.0

I tried drivers 2.11.0 and 2.12.0 but 2.10.0 only works properly in my 11.3
with all X11 updates. Now I run it on 2.6.35-rc6 kernel but I think that
solution will work on 2.6.34 OTB kernel.
Cheers!

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >