Mailinglist Archive: opensuse-bugs (4739 mails)

< Previous Next >
[Bug 606684] New: skge: martian source: ll header: ff:ff:ff:ff:ff:ff:00:15:0c:bd:bb:81:08:00
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 18 May 2010 09:31:33 +0000
  • Message-id: <bug-606684-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=606684

http://bugzilla.novell.com/show_bug.cgi?id=606684#c0


Summary: skge: martian source: ll header:
ff:ff:ff:ff:ff:ff:00:15:0c:bd:bb:81:08:00
Classification: openSUSE
Product: openSUSE 11.3
Version: Factory
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: koenig@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


on my test PC I tried to use the onboard marvell gigabit ethernet chip instead
of the e1000 pci card which is the default NIC (both connected to the same 100
Mbit switch).

dhcp worked fine on eth1, but for every ping from remote PC I got this kernel
msgs (ping, ssh or anything else did not work):

[ 164.612753] martian source 192.168.178.27 from 192.168.178.31, on dev eth1
[ 164.612757] ll header: ff:ff:ff:ff:ff:ff:00:02:b3:b5:42:39:08:06
^^^^^^^^^^^^^^^^^
where 00:02:b3:b5:42:39 is the MAC of the remote pc (source of ping, e100 with
suse 11.1 32bit).

here is some syslog from startup:

a1 kernel: [ 58.308017] skge 0000:00:0a.0: eth1: Link is up at 100 Mbps, full
duplex, flow control both
a1 kernel: [ 58.308171] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
a1 avahi-daemon[2927]: Registering new address record for
fe80::211:2fff:fea7:fa25 on eth1.*.
a1 dhcpcd[4038]: eth1: offered 192.168.178.32 from 192.168.178.1
a1 kernel: [ 60.631793] martian source 255.255.255.255 from 192.168.178.1, on
dev eth1
a1 kernel: [ 60.631797] ll header: ff:ff:ff:ff:ff:ff:00:15:0c:bd:bb:81:08:00
a1 dhcpcd[4038]: eth1: checking 192.168.178.32 is available on attached
networks
a1 kernel: [ 60.708055] martian source 255.255.255.255 from 192.168.178.1, on
dev eth1
a1 kernel: [ 60.708058] ll header: ff:ff:ff:ff:ff:ff:00:15:0c:bd:bb:81:08:00
a1 dhcpcd[4038]: eth1: leased 192.168.178.32 for 864000 seconds
a1 dhcpcd[4038]: eth1: adding IP address 192.168.178.32/24
a1 dhcpcd[4038]: eth1: adding default route via 192.168.178.1 metric 0
a1 dhcpcd[4038]: eth1: adding route to 169.254.0.0/16 metric 0
a1 dhcpcd[4038]: eth1: exiting



later I had to reboot because of some suspend/resume problems, and now eth1
seems to work.
at least I can ping now, but still I see some rare "matian source" messages --
so far 3 of them:

[ 4178.788345] martian source 192.168.178.27 from 192.168.178.31, on dev eth1
[ 4178.788348] ll header: ff:ff:ff:ff:ff:ff:00:02:b3:b5:42:39:08:06
[ 4296.877154] martian source 192.168.178.32 from 192.168.178.31, on dev eth1
[ 4296.877157] ll header: ff:ff:ff:ff:ff:ff:00:02:b3:b5:42:39:08:06
[ 4781.998797] martian source 192.168.178.32 from 192.168.178.31, on dev eth1
[ 4781.998801] ll header: ff:ff:ff:ff:ff:ff:00:02:b3:b5:42:39:08:06

and from this startup:

[ 56.566292] skge 0000:00:0a.0: eth1: enabling interface
[ 56.569824] ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 58.308017] skge 0000:00:0a.0: eth1: Link is up at 100 Mbps, full duplex,
flow control both
[ 58.308171] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 60.631793] martian source 255.255.255.255 from 192.168.178.1, on dev eth1
[ 60.631797] ll header: ff:ff:ff:ff:ff:ff:00:15:0c:bd:bb:81:08:00
[ 60.708055] martian source 255.255.255.255 from 192.168.178.1, on dev eth1
[ 60.708058] ll header: ff:ff:ff:ff:ff:ff:00:15:0c:bd:bb:81:08:00
[ 69.174008] eth1: no IPv6 routers present


is this a known problem for the skge driver and/or marvell ethernet chip?

first I was using the same ethernet cable for skge as before for e1000, so I
don't think (hope?) it's a hardware problem with cable or switch port ?!?
now I have two connections to be able to test skge -- but I need e1000 for safe
remote access (I don't want to rely on the skge yet...;)



hw info:

00:0c.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet
Controller (rev 05)
Subsystem: Intel Corporation PRO/1000 GT Desktop Adapter

00:0a.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit
Ethernet Controller (rev 13)
Subsystem: ASUSTeK Computer Inc. Marvell 88E8001 Gigabit Ethernet
Controller (Asus)

00:0c.0 0200: 8086:107c (rev 05)
00:0a.0 0200: 11ab:4320 (rev 13)

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >