Mailinglist Archive: opensuse-bugs (4692 mails)

< Previous Next >
[Bug 593445] New: eric crashes on startup because PyQt4.Qsci expects sip API v6.0 when v7 is installed
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 2 Apr 2010 18:22:28 +0000
  • Message-id: <bug-593445-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=593445

http://bugzilla.novell.com/show_bug.cgi?id=593445#c0


Summary: eric crashes on startup because PyQt4.Qsci expects sip
API v6.0 when v7 is installed
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.2
Status: NEW
Severity: Critical
Priority: P5 - None
Component: KDE4 Applications
AssignedTo: kde-maintainers@xxxxxxx
ReportedBy: gtschmidt@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.2.0)
Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6

I'm using the KDE 4.4.2 binaries from Factory. I installed
eric-4.4.2-33.4.x86_64 using yast.

Other relevant (according to the error message below) packages are:

python-qt4-4.7.2-41.3.x86_64
python-sip-4.10.1-36.2.x86_64

I let yast do the dependency solving.




Reproducible: Always

Steps to Reproduce:
1. Open a console window.
2. Enter: eri4

Actual Results:
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/eric4/eric4.py", line 60, in
<module>
from KdeQt.KQApplication import KQApplication
File "/usr/lib64/python2.6/site-packages/eric4/KdeQt/__init__.py", line 20,
in <module>
import Preferences
File "/usr/lib64/python2.6/site-packages/eric4/Preferences/__init__.py", line
25, in <module>
from PyQt4 import Qsci
RuntimeError: the sip module implements API v7.0 to v7.1 but the PyQt4.Qsci
module requires API v6.0

Expected Results:
Start the Python IDE.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >