Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 580389] security update fails fuse, gnutls, gnome-screensaver, postfix, flash-player
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 19 Feb 2010 13:05:25 +0000
  • Message-id: <20100219130525.6DEB1CC7CE@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=580389

http://bugzilla.novell.com/show_bug.cgi?id=580389#c6


Ján Kupec <jkupec@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Priority|P5 - None |P2 - High
Status|NEW |NEEDINFO
Info Provider| |kendall.green@xxxxxxxxx

--- Comment #6 from Ján Kupec <jkupec@xxxxxxxxxx> 2010-02-19 13:05:23 UTC ---
The locks are not a problem, this is:

2010-02-16 19:39:12 <1> linux-573a(16560) [zypp] RpmDb.cc(doRemovePackage):1840
RpmDb::doRemovePackage(postfix-2.6.1-2.1.x86_64,0x00000008)
2010-02-16 19:39:12 <1> linux-573a(16560) [zypp++]
ExternalProgram.cc(start_program):221 Executing 'rpm' '--root' '/' '--dbpath'
'/var/lib/rpm' '-e' '--allmatches' '--nodeps' '--' 'postfix-2.6.1-2.1.x86_64'
2010-02-16 19:39:12 <1> linux-573a(16560) [zypp++]
ExternalProgram.cc(start_program):373 pid 17065 launched
2010-02-16 19:39:13 <1> linux-573a(16560) [zypp++]
ExternalProgram.cc(checkStatus):424 Pid 17065 exited with status 1
2010-02-16 19:39:13 <5> linux-573a(16560) [zypp] Exception.cc(log):133
RpmDb.cc(doRemovePackage):1906 THROW: RpmDb.cc(doRemovePackage):1906:
Subprocess failed. Error: RPM failed: error: package postfix-2.6.1-2.1.x86_64
is not installed

Looks like a broken rpm database to me - the solver would otherwise have no
reason to choose a non-installed package for removal.

Please try running 'rpm --rebuilddb' as root and try again.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References