Mailinglist Archive: opensuse-bugs (10135 mails)

< Previous Next >
[Bug 535017] zypper wrongly suggests to remove package with file requirements in case of upgrade
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 12 Nov 2009 03:02:57 -0700
  • Message-id: <20091112100257.C1602245518@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=535017

User mls@xxxxxxxxxx added comment
http://bugzilla.novell.com/show_bug.cgi?id=535017#c5


Michael Schröder <mls@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|REOPENED |CLOSED
Resolution| |INVALID




--- Comment #5 from Michael Schröder <mls@xxxxxxxxxx> 2009-11-12 03:02:56 MST
---
/usr/lib64/libmysqlclient.so.15 is not in the list of supported file provides.
The primary repository data contains only files match the following regexps:
'.*bin\/.*', '^\/etc\/.*', '^\/usr\/lib\/sendmail$'

(libzypp could download the full file lists in that case, but the code isn't
there, yet. libsatsolver already has support for it.)

Anyway, this is also a packaging bug, as dummy-package should use the standard
autogenerated "so" provides/requires, i.e.: "libmysqlclient.so.15()(64bit)".

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >