Mailinglist Archive: opensuse-bugs (7309 mails)

< Previous Next >
[Bug 489846] New: pci passthrough error "non-page-aligned MMIO BAR found"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 27 Mar 2009 14:06:40 -0600 (MDT)
  • Message-id: <bug-489846-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=489846


Summary: pci passthrough error "non-page-aligned MMIO BAR
found"
Classification: openSUSE
Product: openSUSE 11.1
Version: Final
Platform: Other
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Xen
AssignedTo: cgriffin@xxxxxxxxxx
ReportedBy: pgnet.trash@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9)
Gecko/2008052906 Firefox/3.0

i've,

rpm -qa | egrep -i "kernel-xen|^xen-3"
kernel-xen-2.6.27.21-4.1
kernel-xen-base-2.6.27.21-4.1
kernel-xen-extra-2.6.27.21-4.1
xen-3.3.1_18494_03-1.8


on pci passthrough of

# 04:07.0 RAID bus controller: Silicon Image, Inc. SiI 3124 PCI-X Serial ATA
Controller (rev 02)

with config
...
pci = [ '04:07.0', '04:08.0' ]
...

to an OS 11.1 DomU, launch fails with

Error: pci: 0000:04:07.0: non-page-aligned MMIO BAR found.

digging, it's been seen upstream,

http://lists.xensource.com/archives/html/xen-users/2008-09/msg00803.html

but no resolution that i've found as yet.

as the report's hardware is different than mine, i'm guessing Xen's the liekly
culprit?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >