Mailinglist Archive: opensuse-bugs (7307 mails)

< Previous Next >
[Bug 481208] New: osc build --local-package is completely ineffective
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 2 Mar 2009 15:18:44 -0700 (MST)
  • Message-id: <bug-481208-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=481208


Summary: osc build --local-package is completely ineffective
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: Other
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: BuildService
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: ajorgensen@xxxxxxxxxx
QAContact: adrian@xxxxxxxxxx
Found By: ---


according to "osc build --help":
--local-package build a package which does not exist on the server

.. but when I use that option after creating a new project with "osc mkpac" I
get:

Building mono-nat.spec for openSUSE_11.1/x86_64
Getting buildinfo from server
Server returned an error: HTTP Error 404: Not Found
Unknown package 'mypackage'

If I move the .osc away so that it doesn't see it as an obs package I get:

Building mono-nat.spec for openSUSE_11.1/x86_64
Error: '/home/ajorg/packages/Mono:Community/mono-nat' is not an osc project dir
or working copy.


osc build --local-package should do what the --help text says it does. This
would be very useful to packagers.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >