Mailinglist Archive: opensuse-bugs (14433 mails)

< Previous Next >
[Bug 363219] gcc advertises prerelease
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 15 Oct 2008 05:20:15 -0600 (MDT)
  • Message-id: <20081015112015.22495CC6B6@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=363219

User rguenther@xxxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=363219#c12


Richard Guenther <rguenther@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|REOPENED |ASSIGNED




--- Comment #12 from Richard Guenther <rguenther@xxxxxxxxxx> 2008-10-15
05:20:14 MDT ---
As there is no upstream version '4.3' this likely confuses scripts out in the
wild that parse gcc --version output. As there is no pressure for openSUSE I
do absolutely not want to go that way there.

Can you educate customers instead that prerelease != experimental?

gcc-4.4 (SUSE Linux) 4.4.0 20080905 (experimental) [trunk revision 140030]

vs.

gcc-4.3 (SUSE Linux) 4.3.3 20080915 (prerelease) [gcc-4_3-branch revision
140371]

that said, as we tried to teach virtualbox not to parse gcc -dumpversion
(which prints 4.3), but gcc --version (which printed 4.3.x which is what they
expected) it would be strange to now also change that output to 4.3.
Which is why the original solution for SLE probably wasn't too a great idea
either.

Ok, to fulfill this (IMHO silly) request I will change

gcc-4.3 (SUSE Linux) 4.3.3 20080915 (prerelease) [gcc-4_3-branch revision
140371]

to

gcc-4.3 (SUSE Linux) 4.3.2 [gcc-4_3-branch revision 140371]

which should be good enough, as the former was also with additional patches
anyway.

Ok?


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >