Mailinglist Archive: opensuse-bugs (19677 mails)

< Previous Next >
[Bug 391069] bad gnuplot_x11 performace with utf-8
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 26 May 2008 10:42:37 -0600 (MDT)
  • Message-id: <20080526164237.646F924538D@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=391069

User koenig@xxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=391069#c9





--- Comment #9 from Harald Koenig <koenig@xxxxxxxx> 2008-05-26 10:42:37 MDT ---
(In reply to comment #8 from Mike Fabian)
Speed comparison of wxt and x11:

I neer used "wxt" so far, but my first test (64 bit?!) isn't that promising:

( echo "set term wxt" ; for i in {1..100} ; do echo "plot sin(x+$i/10.)
t '$i'" ; done ) | LC_ALL=de_DE time gnuplot
Command terminated by signal 11
^^^^^^^^^
^^^^^^^^^

I'd guess that's the 64bit-version of your

Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Command terminated by signal 6


here is my backtrace (but too helpful?!):

Program terminated with signal 11, Segmentation fault.
[New process 23455]
#0 0x00007f44cb5a33c0 in ?? ()
(gdb) where
#0 0x00007f44cb5a33c0 in ?? ()
#1 0x00007f44d068926d in exit () from /lib64/libc.so.6
#2 0x00007f44d067243d in __libc_start_main () from /lib64/libc.so.6
#3 0x0000000000414e99 in ?? ()
#4 0x00007fffde85d3e8 in ?? ()
#5 0x000000000000001c in ?? ()
#6 0x0000000000000001 in ?? ()
#7 0x00007fffde85f025 in ?? ()
#8 0x0000000000000000 in ?? ()
(gdb)


I think wxt should be the default though.

IMHO at least not as long as it's throwing core files!
(and maybe not as long as it's su much slower (non-utf8!)).

better the gnuplot guys (or X11) will fix the real issue some time but not just
cover it with new problems of "wxt"...


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References