Mailinglist Archive: opensuse-bugs (14006 mails)

< Previous Next >
[Bug 375625] upgrade of libqt4-devel deinstalls libqt4-devel-doc
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 31 Mar 2008 23:48:23 -0600 (MDT)
  • Message-id: <20080401054823.7A57924538E@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=375625

User coolo@xxxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=375625#c5





--- Comment #5 from Stephan Kulow <coolo@xxxxxxxxxx> 2008-03-31 23:48:22 MST
---
your bug is not reproducible and I'm afraid it wasn't even reproducible the
moment you created the test case. Because with the data you have, it would have
done this:

!> Solution :
!> install libQtWebKit4-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-devel-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-devel-doc-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-devel-doc-data-4.3.93.20080325-1.noarch[stable-x86]
!> install libqt4-qt3support-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-sql-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-sql-sqlite-4.3.93.20080325-1.i586[stable-x86]
!> install libqt4-x11-4.3.93.20080325-1.i586[stable-x86]
!> update libQtWebKit4-4.3.93.20080319-1.i586[@System]
!> update libqt4-4.3.93.20080319-1.i586[@System]
!> update libqt4-devel-4.3.93.20080319-1.i586[@System]
!> update libqt4-devel-doc-4.3.93.20080319-1.i586[@System]
!> update libqt4-devel-doc-data-4.3.93.20080319-1.noarch[@System]
!> update libqt4-qt3support-4.3.93.20080319-1.i586[@System]
!> update libqt4-sql-4.3.93.20080319-1.i586[@System]
!> update libqt4-sql-sqlite-4.3.93.20080319-1.i586[@System]
!> update libqt4-x11-4.3.93.20080319-1.i586[@System]

Taking that half the packages are from stable-x86 and half from dirk:playground
I guess dirk:playground wasn't in sync with stable yet and so it was broken for
a millisecond.

At least that's what sat solver gives:
!> upgrade libQtWebKit4-4.3.93.20080319-1.i586 =>
libQtWebKit4-4.3.93.20080325-1.i586[stable-x86]
!> !unflag libqt4-4.3.93.20080319-1.i586[system]
!> upgrade libqt4-4.3.93.20080319-1.i586 =>
libqt4-4.3.93.20080325-1.i586[stable-x86]
!> !unflag libqt4-devel-4.3.93.20080317-3.1.i586[home:dirkmueller:playground]
!> upgrade libqt4-devel-4.3.93.20080319-1.i586 =>
libqt4-devel-4.3.93.20080325-1.i586[stable-x86]
!> !unflag libqt4-devel-doc-4.3.93.20080319-1.i586[system]
!> upgrade libqt4-devel-doc-4.3.93.20080319-1.i586 =>
libqt4-devel-doc-4.3.93.20080325-1.i586[stable-x86]
!> !unflag
libqt4-devel-doc-data-4.3.93.20080317-4.1.noarch[home:dirkmueller:playground]
!> upgrade libqt4-devel-doc-data-4.3.93.20080319-1.noarch =>
libqt4-devel-doc-data-4.3.93.20080325-1.noarch[stable-x86]
!> !unflag libqt4-qt3support-4.3.93.20080319-1.i586[system]
!> upgrade libqt4-qt3support-4.3.93.20080319-1.i586 =>
libqt4-qt3support-4.3.93.20080325-1.i586[stable-x86]
!> !unflag libqt4-sql-4.3.93.20080317-3.1.i586[home:dirkmueller:playground]
!> upgrade libqt4-sql-4.3.93.20080319-1.i586 =>
libqt4-sql-4.3.93.20080325-1.i586[stable-x86]
!> !unflag libqt4-sql-sqlite-4.3.93.20080319-1.i586[system]
!> upgrade libqt4-sql-sqlite-4.3.93.20080319-1.i586 =>
libqt4-sql-sqlite-4.3.93.20080325-1.i586[stable-x86]
!> !unflag libqt4-x11-4.3.93.20080317-3.1.i586[home:dirkmueller:playground]
!> upgrade libqt4-x11-4.3.93.20080319-1.i586 =>
libqt4-x11-4.3.93.20080325-1.i586[stable-x86]

Unfortunately INVALID as it is.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >