Mailinglist Archive: opensuse-bugs (9511 mails)

< Previous Next >
[Bug 373632] New: YaST should not echo password for WPA-EAP configuration
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 25 Mar 2008 09:04:39 -0600 (MDT)
  • Message-id: <bug-373632-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=373632


Summary: YaST should not echo password for WPA-EAP configuration
Product: openSUSE 10.3
Version: Final
Platform: All
OS/Version: openSUSE 10.3
Status: NEW
Keywords: security
Severity: Normal
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: bgmerrell@xxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: Integration Test


PROBLEM STATEMENT:

In both yast and yast2, the password is echoed as it is being typed when
configuring a wireless card to use WPA-EAP.

REPRO:

1. Run yast or yast2 as root (in a machine with a wireless card)
2. Select "Network Card" under "Network Devices"
3. Click/highlight a wireless card and select "Configure"
4. Select "Next" at the "Network Card Setup" screen
5. At the "Wireless Network Card Configuration" screen, enter any ESSID and
select WPA-EAP as the "Authentication Mode." Then click "Next."
6. Type a potential password in the "Password" field.

RESULTS:

The password is echoed to the screen.

EXPECTED RESULTS:

The password should not be echoed the screen. Asterisks should replace each
character in yast, and dots should replace each character in yast2. This is
how other passwords are handled.

COMMENTS:

I filed this under the Yast2 component, is there a reason there isn't a generic
YaST component for both ncurses yast and yast2?


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups