Mailinglist Archive: opensuse-bugs (6120 mails)

< Previous Next >
[Bug 285101] fuse module loaded by default
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 30 Jul 2007 11:17:21 -0600 (MDT)
  • Message-id: <20070730171721.86453CC789@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=285101#c27





--- Comment #27 from Bernhard Kaindl <bk@xxxxxxxxxx>  2007-07-30 11:17:21 MST ---
>> * fuse2          - contains fusermount, mount.fuse, the rc script and docs
> I'd call the package just "fuse" or "fuse-utils".

Yes, didn't think that though. Indeed I think just "fuse" (or "fuse-utils, I'm
not sure what is best)

fuse or fuse-utils should be without version in the name because when fuse goes
3.x, an update upgrades the fuse or fuse-utils package to fuse-3.x and that
works as fusermount of fuse-3.x will be compatible with libfuse2.

> Otherwise this sounds fine.  Do we want *fs packages to depend on the fuse
> package?  Or should the user need to install fuse separately to have a working
> filesystem?

Normally, way we'd do such things this way: If a package is installed, it
should
be basically or mostly useable without having to install further packages, this
is the whole point of having package dependices, so I'd say.

As to what they should require, I think that instead of requiring "fuse" or
"fuse-tools", they may (in case we may change the name of the package or split
furhter) also require specifically fusermount, either by requiring
/usr/bin/fusermount as path, but as they do not need it in a specific path,
they may also require just have "fusermount" and the whichever package provides
fusermount would then have "Provides: fusermount", independent of it's name.
The label could also include the API of the fusermount requiured and provided,
e.g. "fusermount-v2" would also be possible.

At the moment, I think I prefer such provides/requires string with such API
version added as that would give total freedom on which package provides it and
it also means that one is free to drop that provides once that API is not
longer provided or moved to a different package. I know this is very very
generic,
but this way the control is over the provides string and that's very flexible.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >