Mailinglist Archive: opensuse-bugs (6456 mails)

< Previous Next >
[Bug 273614] check if we can include yast2-gtk
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 11 May 2007 04:38:01 -0600 (MDT)
  • Message-id: <20070511103801.7160625C887@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=273614





------- Comment #4 from mmeeks@xxxxxxxxxx  2007-05-11 04:38 MST -------
Well; "check we can include yast2-gtk" is a nicer summary than "do not use
yast2-gtk"; better would be:

"work out why Marcus wants to remove yast2-gtk - and do something about it" ;-)

Wrt. "are you committed to fix all bugs, missing features & stability issues" -
what kind of question is that ? :-) I can't swear the software is bug-free,
what bugs in particular are you thinking of - please do file them.

Here are all the bugs we've worked on (that I know of):

Fixed:
        + n#247682 - search for umlauts        - fixed 2007-03-15
        + n#247683 - freeze in 'language'      - fixed 2007-03-15
        + n#247802 - save to File just freezes - fixed 2007-03-15
        + n#265311 - crash on update.ycp start - fixed 2007-04-23
                [ was also incidentally a core update.ycp bug ]
        + n#268146 - missing 'search' button   - fixed 2007-05-07
In progress:
        + n#268167 - multi-select in pkg installer 
        + n#271716 - crash during package install [ kdedu3 install ]

yast2-gtk is under active development, pwrt. the package selector, as you can
see in svn. It is true, I havn't been following the autobuild bits as well as
possible, and we should push a new release with the recent fixes.

Unfortunately chasing down the latest autobuild messages:

JFYI: package yast2-gtk failed to build in distribution beta-x86_64.
..
In file included from /usr/include/YaST2/yui/YUI.h:35,
                 from ./YGUI.h:9,
                 from dummy.cc:5:
/usr/include/YaST2/yui/YWidget.h: In member function 'virtual char*
YWidget::widgetClass()':
/usr/include/YaST2/yui/YWidget.h:65: warning: deprecated conversion from string
constant to 'char*'
..
/usr/lib64/libycp.so: undefined reference to `std::basic_ostream<char,
std::char_traits<char> >::_M_insert(char const*, long)@GLIBCXX_3.4.9'
collect2: ld returned 1 exit status
make[2]: *** [dummy] Error 1

Seems to highlight normal underlying yast2 breakage - was that what you were
thinking of ? Unusally we actually link a 'dummy' binary with the platform libs
to see if all is well at build time to avoid unpredictable lazy linking related
run-time errors - not sure other modules do that. What metric are you using to
determine un-maintained-ness ? :-)

Also - another unfortunate problem with verifying the 64bit situation currently
is that (apparently) autobuild is broken thus (log attached)

[snip ...]
expanding package dependencies
kuckuk:/suse/mmichael/yast2-gtk # nothing provides libparted-1.8.so.6()(64bit)
needed by hal
expansion failed.
init_buildsystem failed.
[snip]

which is apparently normal, and one just 'waits' until it works again (?) ;-)


Anyhow - punch-line, I'm having problems identifying your specific issue, but
would love to help.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
References