Mailinglist Archive: opensuse-bugs (6366 mails)

< Previous Next >
[Bug 270270] New: wireless doesn't work if network manager is used
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 1 May 2007 08:33:48 -0600 (MDT)
  • Message-id: <bug-270270-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=270270

           Summary: wireless doesn't work if network manager is used
           Product: openSUSE 10.2
           Version: Final
          Platform: i686
        OS/Version: openSUSE 10.2
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: Network
        AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
        ReportedBy: teheo@xxxxxxxxxx
         QAContact: qa@xxxxxxx


This happens on Eurohotel's (yeap, in Nuremberg) paid wireless service.  The
network manager successfully lists the ESSID and sometimes successfully
connects too but in general it doesn't work.  The weird thing is that wireless
begins to work at the moment I turn off Wireless in the right click menu of
nm-applet.

*** network manager is trying to connect

# iwconfig eth1
eth1      unassociated  ESSID:"Eurohotel"  
          Mode:Managed  Frequency=2.432 GHz  Access Point: 00:30:42:0A:C1:C1   
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:21   Missed beacon:0

*** check disable wireless in the nm-applet

eth1      IEEE 802.11g  ESSID:"Eurohotel"  
          Mode:Managed  Frequency:2.432 GHz  Access Point: 00:30:42:0A:C1:BD   
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=67/100  Signal level=-61 dBm  Noise level=-90 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:300  Invalid misc:21   Missed beacon:0

There is no visible configuration difference.  This works the other way too. 
While the network is working, if I turn on wireless in the nm-applet, it dies. 
The network card is ipw2200.

  06:05.0 Network controller [Class 0280]: Intel Corporation PRO/Wireless
2915ABG Network Connection [8086:4223] (rev 05)

Any ideas?  I can get on the network manually using iwconfig and dhcpcd but I
really miss that small antenna graph and gaim refuses to connect if the network
manager says the network is off.


-- 
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >
Follow Ups