Mailinglist Archive: opensuse-bugs (8080 mails)

< Previous Next >
[Bug 238680] yast2-slp should not needed in minimal installed system
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 6 Feb 2007 03:57:32 -0700 (MST)
  • Message-id: <20070206105732.3F75CF17@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=238680


jsuchome@xxxxxxxxxx changed:

What |Removed |Added
----------------------------------------------------------------------------
CC|snwint@xxxxxxxxxx |




------- Comment #13 from jsuchome@xxxxxxxxxx 2007-02-06 03:57 MST -------
Hm, I think I like the Perl solution more than WFM::call:

- my ui.ycp calls SLPAPI::FindSrvs instead of SLP::FindSrvs,
but only after it checks yast2-slp is installed
- SLPAPI.pm is Perl module, which only wraps parts of SLP.ycp API (so
SLPAPI::FindSrvs only calls SLP::FindSrvs)
- importing SLPAPI.pm doesn't require to have SLP.ycp installed.

What I like on this solution is some transparency at ui.ycp level.
SLPAPI.pm could be in yast2.rpm if other than yast2-ldap-client modules would
like to use it.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >