Mailinglist Archive: opensuse-bugs (8080 mails)

< Previous Next >
[Bug 237145] etc/dbus-1/system.d/avahi-dbus.conf uses nonexisting group netdev
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 1 Feb 2007 03:36:39 -0700 (MST)
  • Message-id: <20070201103639.88292FC0@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=237145


lgt1@xxxxxxxxxxxxx changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |lgt1@xxxxxxxxxxxxx
Priority|P5 - None |P3 - Medium




------- Comment #2 from lgt1@xxxxxxxxxxxxx 2007-02-01 03:36 MST -------
I think this might be more serious than just a log warning. On my
previously-working 10.2 system, I installed Ekiga, which in turn requires avahi
to be installed. After this, I could no longer open windows for removable
devices... "Cannot contact PolicyKit". Took some debugging, but I finally found
that polkitd (Policy Kit Daemon), which is used to authorize access to various
devices and services, was crashing at system startup just after complaining
about the unknown group 'netdev'. I tracked this down to a policy rule in
avahi-dbus.conf. After removing avahi (and Ekiga) and rebooting, polkitd
started just fine and I could now open removable devices again.

I may have a second 10.2 system with possibly the same problem but I haven't
had a chance to check if polkitd is running yet - will report back when I have.
I'm upping the priority of this bug as it has random effects on other parts of
the system as well, which an average user would probably not be able to
diagnose.


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

< Previous Next >