Mailinglist Archive: opensuse-autoinstall (54 mails)

< Previous Next >
[opensuse-autoinstall] rules.xml on DVD install
  • From: Jeromy Smith <jeromy@xxxxxxxx>
  • Date: Mon, 5 Oct 2009 17:23:07 -0500
  • Message-id: <500e16a60910051523s412fa156w98554e65cc2f3c72@xxxxxxxxxxxxxx>
 I am trying to add my rules to a openSUSE 11.1 DVD installation medium.  I
 need the rules to reside on the DVD instead of an ftp, etc server.  I have
 verified that my rules work when I invoke the install using autoyast=
 ftp://192.168.1.120/autoyast/11.1/x86_64/ where the rules reside under
 rules/rules.xml and the profiles are in autoyast/11.1/x86_64/.

 When I try to copy the files to the DVD, I have problems.  It seems to find
 the rules.xml when I put it on the DVD under /rules.  When it comes time to
 copy the profiles, this is where the problem arises.  After the rules have
 run, I see this in the y2log:

 [YCP] autoinstall/io.ycp:119 Copy profile: cp /default.xml
 /tmp/YaST2-03147-PNVUlC/rules/
default.xml
 [bash] ShellCommand.cc(shellcommand):78 cp: missing destination file operand
 after '/default.xml'
 [bash] ShellCommand.cc(shellcommand):78 Try 'cp --help' for more
 information.
 [bash] ShellCommand.cc(shellcommand):78 sh: line 1:
 /tmp/YaST2-03147-PNVUlC/rules/default.xml: No such file or directory

 Any suggestions on how to fix this?  I've already read over the
 documentation, FAQ, and everything google turned up.  I'm pretty desperate
 at this point.

 Jeromy
--
To unsubscribe, e-mail: opensuse-autoinstall+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-autoinstall+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups