Mailinglist Archive: opensuse-autoinstall (52 mails)

< Previous Next >
[opensuse-autoinstall] Adding repository for 11.0
  • From: Bernhard Walle <bwalle@xxxxxxx>
  • Date: Sun, 13 Jul 2008 15:04:51 +0200
  • Message-id: <20080713150451.75950b68@xxxxxxxxxxxxxxx>
Hi,

when I add a repo as "addon source" like

------------ 8< -------------------------
<add-on>
<add_on_products config:type="list">
<listentry>

<media_url>http://download.opensuse.org/distribution/11.0/repo/oss</media_url>
<product>openSUSE 11.0 OSS</product>
<product_dir>/</product_dir>
</listentry>
</add_on_products>
------------ >8 --------------------------

that fails because the "installation.xml" file cannot be found
(according to YaST logs).

------------ 8< -------------------------
[zypp] PathInfo.cc(_Log_Result):295 unlink
/var/adm/mount/AP_0x00000001/installation.xml.new.zypp.erCn6a
[zypp] Exception.cc(log):119 MediaCurl.cc(doGetFileCopy):1279 THROW:
MediaCurl.cc(doGetFileCopy):1279: File '/installation.xml' not found on medium
'http://download.opensuse.org/distribution/11.0/repo/oss/'
[zypp] Exception.cc(log):119
[zypp] Exception.cc(log):119 MediaCurl.cc(doGetFileCopy):1341 RETHROW:
MediaCurl.cc(doGetFileCopy):1279: File '/installation.xml' not found on medium
'http://download.opensuse.org/distribution/11.0/repo/oss/'
[zypp] Exception.cc(log):119
[zypp] Exception.cc(log):119 MediaCurl.cc(getFileCopy):800 RETHROW:
MediaCurl.cc(doGetFileCopy):1341: File '/installation.xml' not found on medium
'http://download.opensuse.org/distribution/11.0/repo/oss/'
[zypp] Exception.cc(log):119
[zypp] Exception.cc(log):119 MediaSetAccess.cc(provideFileInternal):259
CAUGHT: MediaCurl.cc(getFileCopy):800: File '/installation.xml' not found on
medium 'http://download.opensuse.org/distribution/11.0/repo/oss/'
[zypp] Exception.cc(log):119
[zypp] MediaHandler.cc(disconnect):692 Disconnected:
http://download.opensuse.org/distribution/11.0/repo/oss/ attached; localRoot
"/var/adm/mount/AP_0x00000001"
[zypp] PathInfo.cc(_Log_Result):295 recursive_rmdir
/var/adm/mount/AP_0x00000001
[zypp] MediaHandler.cc(removeAttachPoint):190 Deleted default attach point
/var/adm/mount/AP_0x00000001
[zypp] MediaHandler.cc(release):774 Released:
http://download.opensuse.org/distribution/11.0/repo/oss/ not attached;
localRoot ""
[zypp] MediaManager.cc(releaseAll):695 Releasing all attached media
[zypp] MediaManager.cc(releaseAll):723 Exit
[zypp] MediaSetAccess.cc(provideFileInternal):314 ProvideFile exception
caught, callback answer: 0
[zypp] Exception.cc(log):119 MediaSetAccess.cc(provideFileInternal):319
RETHROW: MediaCurl.cc(getFileCopy):800: File '/installation.xml' not found on
medium 'http://download.opensuse.org/distribution/11.0/repo/oss/'
------------ >8 --------------------------

How can I add the full 11.0 source to AutoYaST so that I can specify
packages like in

------------ 8< -------------------------
<software xmlns:config="http://www.suse.com/1.0/configns";>
<packages config:type="list">
<package>openipmi</package>
</packages>
</software>
------------ >8 --------------------------

I didn't find anything in the documentation. Thanks!



Bernhard
--
Bernhard Walle, SUSE LINUX Products GmbH, Architecture Development
--
To unsubscribe, e-mail: opensuse-autoinstall+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-autoinstall+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups