Mailinglist Archive: opensuse-autoinstall (120 mails)

< Previous Next >
autoinstall with LVM, GRUB, SWAP
  • From: Manuel.Laesser@xxxxxxxxxxxx
  • Date: Fri, 19 Mar 2004 12:53:34 +0000 (UTC)
  • Message-id: <OFF2F2B8C8.FBE38E3C-ONC1256E5C.003948BE-C1256E5C.0046CF0D@xxxxxxxxxxxx>
Hello,

I've got the following questions.

1. Is there a possibility in the autoinst.mxl to deselect lilo explicit so
it won't be installed. I can't find a lilo statement in my package section
but the rpm still will be installed. I got a hint from a friend. He told
me that I should deselct lilo explicit in the autoinstall.xml. Is there a
way to do this? Could this be a valuable way of having GRUB instead of
LILO. If I understood Anas statement, then it's not possible to have GRUB
if LVM is used with an autoinstall. Is there any workaround? Can I migrate
from LILO to GRUB using a post installation script?

2. If you use LVM and create a logical volume for /, /home, /usr and swap
the swap partition isn't activated and there is no entry in /etc/fstab but
the logical volume exists. After I put the entry in /etc/fstab and made a
mkswap, swapon -a the swap space was available. 10 minutes later I checkd
with swapon -s or cat /proc/swaps and it was saying that the swap space
was deleted??!! Did anyone receive a similar message?

Thank you very much for your answer. I'm a little bit depressed, because I
still have no concept how I can carry out my degree dissertation.....and
time is bloody short!! :-(

Regards Manuel
< Previous Next >
This Thread
  • No further messages