Mailinglist Archive: opensuse-autoinstall (92 mails)

< Previous Next >
Re: [suse-autoinstall] rpm update errors
  • From: Richard Bos <radoeka@xxxxxxxxx>
  • Date: Wed, 16 Jul 2003 18:08:10 +0000 (UTC)
  • Message-id: <200307162006.07866.radoeka@xxxxxxxxx>
Op woensdag 16 juli 2003 16:58, schreef Ricardo Kleemann:
> Hello,
>
> I use the online_update script via cron to download
> packages, and then I use it manually to install packages.
>
> Recently, updates to apache2 were downloaded, but running
> online_update -i returns an error when trying to update
> apache.
>
> So then I decided to try updating apache manually via rpm,
> here are the errors:
>
> # rpm -Uvh apache2-2.0.46-3.i586.rpm
> error: failed dependencies:
> libapr0 = 2.0.46 is needed by apache2-2.0.46-3
> apache2 = 2.0.44 is needed by
> apache2-devel-2.0.44-38
> apache_mmn_20020903_0 is needed by
> apache2-prefork-2.0.44-38
> apache_mmn_20020903_0 is needed by
> apache2-mod_perl-1.99_08-29
>
> # rpm -Uvh apache2-devel-2.0.46-3.i586.rpm
> error: failed dependencies:
> apache2 = 2.0.46 is needed by apache2-devel-2.0.46-3

It looks like you downloaded and are installing a patch rpm that misses some
patch rpms that have been released before the ones mentioned above. This can
be solved by obtaining the full rpm and install that one instead. The
dependency you see above is of another nature that yast can take care off.

--
Richard Bos
Without a home the journey is endless


< Previous Next >
References