Mailinglist Archive: opensuse-amd64 (203 mails)

< Previous Next >
Re: [suse-amd64] Problem compiling Qt application on Suse 9.3
  • From: Brad Bourn <brad@xxxxxxxxxxxx>
  • Date: Tue, 7 Jun 2005 20:03:26 +0000 (UTC)
  • Message-id: <200506071405.20589.brad@xxxxxxxxxxxx>
And looks like it depends on the stuff in ./mkspecs/linux-g++-64

specifically the qmake.conf file

I remember having to tweak something (been a while since I changed versions of
qt, have re-compiled it for 9.3 though).

Here is what I have if yours might be different.


#
# $Id: qt/qmake.conf 3.3.4 edited Aug 18 21:25 $
#
# qmake configuration for linux-g++
#
# mkspec for platforms that have both lib and lib64
# directories, like the AMD Opteron.
#

MAKEFILE_GENERATOR = UNIX
TEMPLATE = app
CONFIG += qt warn_on release incremental link_prl
QMAKE_INCREMENTAL_STYLE = sublib

QMAKE_CC = gcc
QMAKE_LEX = flex
QMAKE_LEXFLAGS =
QMAKE_YACC = yacc
QMAKE_YACCFLAGS = -d
QMAKE_CFLAGS = -pipe
QMAKE_CFLAGS_DEPS = -M
QMAKE_CFLAGS_WARN_ON = -Wall -W
QMAKE_CFLAGS_WARN_OFF = -w
QMAKE_CFLAGS_RELEASE = -O2
QMAKE_CFLAGS_DEBUG = -g
QMAKE_CFLAGS_SHLIB = -fPIC
QMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
QMAKE_CFLAGS_THREAD = -D_REENTRANT

QMAKE_CXX = g++
QMAKE_CXXFLAGS = $$QMAKE_CFLAGS
QMAKE_CXXFLAGS_DEPS = $$QMAKE_CFLAGS_DEPS
QMAKE_CXXFLAGS_WARN_ON = $$QMAKE_CFLAGS_WARN_ON
QMAKE_CXXFLAGS_WARN_OFF = $$QMAKE_CFLAGS_WARN_OFF
QMAKE_CXXFLAGS_RELEASE = $$QMAKE_CFLAGS_RELEASE
QMAKE_CXXFLAGS_DEBUG = $$QMAKE_CFLAGS_DEBUG
QMAKE_CXXFLAGS_SHLIB = $$QMAKE_CFLAGS_SHLIB
QMAKE_CXXFLAGS_YACC = $$QMAKE_CFLAGS_YACC
QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD

QMAKE_INCDIR =
QMAKE_LIBDIR =
QMAKE_INCDIR_X11 = /usr/X11R6/include
QMAKE_LIBDIR_X11 = /usr/X11R6/lib64
QMAKE_INCDIR_QT = $(QTDIR)/include
QMAKE_LIBDIR_QT = $(QTDIR)/lib
QMAKE_INCDIR_OPENGL = /usr/X11R6/include
QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib64

QMAKE_LINK = g++
QMAKE_LINK_SHLIB = g++
QMAKE_LFLAGS =
QMAKE_LFLAGS_RELEASE =
QMAKE_LFLAGS_DEBUG =
QMAKE_LFLAGS_SHLIB = -shared
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
QMAKE_RPATH = -Wl,-rpath,

QMAKE_LIBS =
QMAKE_LIBS_DYNLOAD = -ldl
QMAKE_LIBS_X11 = -lXext -lX11 -lm
QMAKE_LIBS_X11SM = -lSM -lICE
QMAKE_LIBS_NIS = -lnsl
QMAKE_LIBS_QT = -lqt
QMAKE_LIBS_QT_THREAD = -lqt-mt
QMAKE_LIBS_OPENGL = -lGLU -lGL -lXmu
QMAKE_LIBS_OPENGL_QT = -lGL -lXmu
QMAKE_LIBS_THREAD = -lpthread

QMAKE_MOC = $(QTDIR)/bin/moc
QMAKE_UIC = $(QTDIR)/bin/uic

QMAKE_AR = ar cqs
QMAKE_RANLIB =

QMAKE_TAR = tar -cf
QMAKE_GZIP = gzip -9f

QMAKE_COPY = cp -f
QMAKE_COPY_FILE = $(COPY)
QMAKE_COPY_DIR = $(COPY) -r
QMAKE_MOVE = mv -f
QMAKE_DEL_FILE = rm -f
QMAKE_DEL_DIR = rmdir
QMAKE_STRIP = strip
QMAKE_STRIPFLAGS_LIB += --strip-unneeded
QMAKE_CHK_DIR_EXISTS = test -d
QMAKE_MKDIR = mkdir -p














On Tuesday 07 June 2005 01:53 pm, Brad Bourn wrote:
> here is the script that I use
>
>
> ./configure $1 $2 -platform linux-g++-64 -system-nas-sound -qt-sql-mysql
> -qt-gif -thread -stl
>
> On Tuesday 07 June 2005 01:47 pm, Thomas Köhler wrote:
> > Hello,
> >
> > I tried to compile some Qt applications on a new installed Suse 9.3 on a
> > AMD 64 bit processor.
> > After
> > ./configure --prefix=.....
> >
> > I get the error
> > ....
> > checking for libjpeg6b... no
> > checking for libjpeg... no
> > configure: WARNING: libjpeg not found. disable JPEG support.
> > checking for perl... /usr/bin/perl
> > checking for Qt... configure: error: Qt (>= Qt 3.2) (library qt-mt) not
> > found. Please check your installation!
> > For more details about this problem, look at the end of config.log.
> > Make sure that you have compiled Qt with thread support!
> > ....
> >
> > config.log shows
> >
> > ....
> > configure:28403: checking for Qt
> > configure: 28468: /usr/lib/qt3/include/qstyle.h
> > taking that
> > tried NO
> > configure:28586: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor
> > -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi
> > -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion
> > -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute
> > -fno-exceptions
> > -fno-check-new -fno-common -I/usr/lib/qt3/include -I/usr/X11R6/include
> > -DQT_THREAD_SUPPORT -D_REENTRANT -L/usr/lib/qt3/lib -L/usr/X11R6/lib64
> > conftest.cc -lqt-mt -lpng -lz -lm -ldl -lXext -lX11 -lSM -lICE
> > -lpthread 1>&5
> > /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.5/../../../../x86_64-suse-linux/
> >bi n/ld: skipping incompatible /usr/lib/qt3/lib/libqt-mt.so when searching
> > for -lqt-mt
> > /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.5/../../../../x86_64-suse-linux/
> >bi n/ld: cannot find -lqt-mt
> > collect2: ld returned 1 exit status
> > ....
> >
> > libqt-mt is present in a 32 and a 64 bit version:
> >
> > /usr/lib/qt3/lib/libqt-mt.so.3
> > /usr/lib/qt3/lib/libqt-mt.la
> > /usr/lib/qt3/lib/libqt-mt.so
> > /usr/lib/qt3/lib/libqt-mt.so.3.3.4
> > /usr/lib/qt3/lib/libqt-mt.so.3.3
> > /usr/lib/qt3/lib64/libqt-mt.so.3
> > /usr/lib/qt3/lib64/libqt-mt.prl
> > /usr/lib/qt3/lib64/libqt-mt.la
> > /usr/lib/qt3/lib64/libqt-mt.so
> > /usr/lib/qt3/lib64/libqt-mt.so.3.3.4
> > /usr/lib/qt3/lib64/libqt-mt.so.3.3
> > /usr/lib/libqt-mt.so.3
> > /usr/lib64/libqt-mt.so.3
> >
> > Any ideas?
> >
> > Best regards,
> >
> > Thomas

< Previous Next >