Mailinglist Archive: opensuse-buildservice (145 mails)

< Previous Next >
Re: [opensuse-buildservice] Have choice: libjack-dev
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Mon, 21 Nov 2011 17:40:07 +0100
  • Message-id: <1736291.WGge0V8lqk@scherben>
Am Montag, 21. November 2011, 11:00:52 schrieb Claudio Freire:
On Mon, Nov 21, 2011 at 5:29 AM, Adrian Schröter <adrian@xxxxxxx> wrote:
Am Sonntag, 20. November 2011, 17:52:14 schrieb Claudio Freire:
I have a source package from universe (libopenal-dev) that I need as a
dependency for build Ubuntu 11.10 oneiric.
It depends itself on libjack-dev, which is a virtual package provided
by libjack-jackd2-dev.

I get "have coice for libjack-dev needed by portaudio19-dev:
libjack-dev libjack-jackd2-dev"

Any of the two would be ok, the virtual package I think would be the
preferred, that's why it's there, but I suspect the build system will
get confused (it already has the requirement to install the virtual
package, yet it's confused). I'm not sure why the confusion, but I bet
adding libjack-jackd2-dev as preference would fix it.

I would love it for someone to add that preference in OBS ;-)

did this.

Sorry for pestering, but I noticed the same issue happens on Ubuntu 11.04.
Same exact solution, if you don't mind ;-)

done

--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups