Mailinglist Archive: opensuse-buildservice (306 mails)

< Previous Next >
[opensuse-buildservice] package conflicts with SLES 11 sp1 migration patch
  • From: "Andrew Daugherity" <adaugherity@xxxxxxxx>
  • Date: Tue, 29 Jun 2010 11:08:42 -0500
  • Message-id: <4C29D43A020000F20002FC7E@xxxxxxxxxxxxxxxx>
Some packages installed via the build service (notably,
apache2-mod_auth_mysql [1]) conflict with the sp1 migration patch, for
no apparent (to me) reason. (Note: I still haven't upgraded to sp1 on
this machine, just keeping its patches up to date, one of which is this
"migration" patch, which is apparently needed pre-upgrade.)

There appears to be a workaround -- choosing to uninstall the affected
package lets the patch install, and I can reinstall the package
afterwards without any conflicts. I don't see any reason for the
conflict in the first place, as it's apparently not in the RPM itself.
Zypper session follows:
====
webdev:~ # zypper patch
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: product:SUSE_SLES-11-73.1.100.x86_64 obsoletes
apache2-mod_auth_mysql < 3.0.0-15 provided by
apache2-mod_auth_mysql-3.0.0-4.1.x86_64
Solution 1: replacement of apache2-mod_auth_mysql-3.0.0-4.1.x86_64 with
product:SUSE_SLES-11-73.1.100.x86_64
Solution 2: do not install patch:slessp0-SP1-Migration-2484.noarch

Choose from above solutions by number or cancel [1/2/C]: 2
Resolving dependencies...
Resolving package dependencies...
Nothing to do.
webdev:~ # zypper patch
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: product:SUSE_SLES-11-73.1.100.x86_64 obsoletes
apache2-mod_auth_mysql < 3.0.0-15 provided by
apache2-mod_auth_mysql-3.0.0-4.1.x86_64
Solution 1: replacement of apache2-mod_auth_mysql-3.0.0-4.1.x86_64 with
product:SUSE_SLES-11-73.1.100.x86_64
Solution 2: do not install patch:slessp0-SP1-Migration-2484.noarch

Choose from above solutions by number or cancel [1/2/C]: 1
Resolving dependencies...
Resolving package dependencies...

The following package is going to be upgraded:
sles-release


The following product is going to be upgraded:
SUSE_SLES


The following NEW patch is going to be installed:
slessp0-SP1-Migration


The following package is going to be REMOVED:
apache2-mod_auth_mysql


Overall download size: 17.0 K. After the operation, 99.0 K will be
freed.
Continue? [YES/no]: y
Retrieving package sles-release-11-73.1.100.x86_64 (1/3), 17.0 K (51.0 K
unpacked)
Retrieving: sles-release-11-73.1.100.x86_64.rpm [done]
Installing: sles-release-11-73.1.100 [done]
webdev:~ # rpm -qi apache2-mod_auth_mysql
package apache2-mod_auth_mysql is not installed
webdev:~ # zypper in !$
zypper in apache2-mod_auth_mysql
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
apache2-mod_auth_mysql


The following package is not supported by its vendor:
apache2-mod_auth_mysql


Overall download size: 32.0 K. After the operation, additional 99.0 K
will be used.
Continue? [YES/no]:
Retrieving package apache2-mod_auth_mysql-3.0.0-4.1.x86_64 (1/1), 32.0 K
(99.0 K unpacked)
Retrieving: apache2-mod_auth_mysql-3.0.0-4.1.x86_64.rpm [done]
Installing: apache2-mod_auth_mysql-3.0.0-4.1 [done]
====


Is it correct that I should continue using packages from "SLE 11" repos
in sp1, etc.? There isn't a separate sp1 repo for e.g. Apache:Modules.
However there is a separate choice for sp1 in the form at
http://software.opensuse.org/search , which doesn't find very much
software compared to SLE-11 (but there is some, e.g. asterisk). This is
a bit confusing.


[1] Installed from the repo at
http://download.opensuse.org/repositories/Apache:/Modules/SLE_11/

--
Andrew Daugherity <adaugherity@xxxxxxxx>
Texas A&M University

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >