Mailinglist Archive: opensuse-buildservice (344 mails)

< Previous Next >
Re: [opensuse-buildservice] _product and ISO generation
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Sat, 29 May 2010 09:37:31 +0200
  • Message-id: <201005290937.31909.adrian@xxxxxxx>
On Freitag, 28. Mai 2010 22:44:55 Troy Telford wrote:
On Friday, May 28, 2010 01:14:12 pm Adrian Schröter wrote:
On Freitag, 28. Mai 2010 20:13:44 Troy Telford wrote:
...

http://obsapi.americas.sgi.com/source/ISO_TEST/_product?cmd=deleteuploadr
ev Server returned an error: HTTP Error 403: Forbidden

k, definitive a bug. But I can not reproduce it here with OBS 2.0 beta 2.
And I am quite sure we would noticed this one with 1.7.x quite soon as
well.

Can you check the api server log file ? Usually

/srv/www/obs/api/log/production.log

Maybe you need to switch on debugging via

config.log_level = :debug

to see more.

$ sudo tail -f production.log
...
[D|#15950] dispatch_command: trying to call method
'index_package_deleteuploadrev'
[D|#15950] [backend] POST: /source/ISO_TEST/_product?cmd=deleteuploadrev
[I|#15950] Sending data
[I|#15950] Completed in 19ms (View: 0, DB: 3) | 200 OK
[http://obsapi.foo.bar.com/source/ISO_TEST/_product?cmd=deleteuploadrev]

So api reports a 200 OK and osc sees a 403 ?
Time to check the lighttpd logs ...


...

have fun!

I managed to get an ISO image created; so I am having fun. Thanks.

great :)

bye
adrian

--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >