Mailinglist Archive: opensuse-buildservice (344 mails)

< Previous Next >
Re: [opensuse-buildservice] _product and ISO generation
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Fri, 28 May 2010 21:14:12 +0200
  • Message-id: <201005282114.12724.adrian@xxxxxxx>
On Freitag, 28. Mai 2010 20:13:44 Troy Telford wrote:
...
http://obsapi.americas.sgi.com/source/ISO_TEST/_product?cmd=deleteuploadrev
Server returned an error: HTTP Error 403: Forbidden

k, definitive a bug. But I can not reproduce it here with OBS 2.0 beta 2.
And I am quite sure we would noticed this one with 1.7.x quite soon as well.

Can you check the api server log file ? Usually

/srv/www/obs/api/log/production.log

Maybe you need to switch on debugging via

config.log_level = :debug

to see more.

...

Are you aware that you need really a full build of the distribution to
create products ? Just having the :full directory filled is not enough,
you need also all the binaries in /obs/build/$PROJECT/$standard/$arch/
directory.

Let's not get ahead of ourselves. I'm not able to check in _product. Thus,
no kiwi files are being generated, _package:* are also not being generated.

I've found (through trial and error) that 'osc ci' doesn't like _any_ files
with the extension *.inc. I can even create a 'junk' package (named
anything;
it doesn't have to be _product), and if I try to add a file named foo.inc and
check it in, I see the same error:

Interessting, either our filename validation code wents wrong or this may be a
rails
bug. Can you tell which OBS version and which base system do you use ?
Do you use our packages or is it installed from git ?

As a workaround you can rename the file to any other name. You just need to
adapt the include statements in the .product files afterwards.

...

If I rename the '*.inc' files to '*.xml', and modify the .product files to
match, then I can successfully run 'osc ci'. At that point, the _product:*
packages are auto-generated and I get .kiwi files. Why OBS is worried about
the '*.inc' extension, I'm not sure.

oh, you found out ;)

Then the build fails in kiwi, probably for the reason you stated above...

(Kiwi output:)
[I] STEP 3 [collectPackages]
[I] Handle scripts for metafiles and metapackages
[E] Metapackage <skelcd-openSUSE> not available for architecure <x86_64>!

yep.

In the end, what I want to do is have something more like the OpenSUSE:Tools
_product -- an add-on package to a distro. (OpenSUSE would be nice, but SLES
11+ is mandatory.) Fortunately, I can look at the OpenSUSE:Tools _product
for
guidance.

okay, when you build all your packages on the media in your OBS, you will not
have this problem.

have fun!
adrian

--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups