Mailinglist Archive: opensuse-buildservice (366 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: openSUSE:Tools/obs-server too old, please update (to version on build.opensuse.org)
  • From: James Oakley <jfunk@xxxxxxxxxxxxxx>
  • Date: Tue, 14 Aug 2007 12:34:49 -0300
  • Message-id: <200708141234.49409.jfunk@xxxxxxxxxxxxxx>
On Tuesday 14 August 2007 11:32 am, Martin Mohring wrote:
> Hi,
>
> sorry, no luck.
>
> when I do the suggested update, I get:
> :/srv/www/obs/frontend # rake migrate
>
> /usr/bin/rake:17:Warning: require_gem is obsolete.  Use gem instead.
> (in /srv/www/obs/frontend)
> Cannot find gem for Rails ~>1.2.3.0:
>     Install the missing gem with 'gem install -v=1.2.3 rails', or
>     change environment.rb to define RAILS_GEM_VERSION with your desired
> version.
>
> rake aborted!
> exit
> /srv/www/obs/frontend/Rakefile:4
> (See full trace by running task with --trace)
>
> What did I do wrong?

You need a new version of rails. Assuming you're installing on 10.2, add 
http://software.opensuse.org/download/ruby/openSUSE_10.2/ to your package ;
manager and update the rubygem-rails package.

-- 
James Oakley
jfunk@xxxxxxxxxxxxxx
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >