Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
Re: [opensuse-buildservice] osc on SLE_10
  • From: Carsten Schoene <cs@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Tue, 26 Jun 2007 23:34:30 +0200
  • Message-id: <46818666.1080306@xxxxxxxxxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Peter,

Dr. Peter Poeml schrieb:
> Hi Carsten,
> 
> On Tue, Jun 26, 2007 at 06:23:36AM +0200, Carsten Schoene wrote:
>> i just installed osc & build on a fresh SLES 10 SP1 from
>http://software.opensuse.org/download/openSUSE:/Tools/SLE_10/
>>
>>
>> When i run osc i get the following error, do i miss something ?
>>
>> sles10basic:/home # osc
>> Traceback (most recent call last):
>>   File "/usr/bin/osc", line 7, in ?
>>     from osc import commandline
>>   File "/usr/lib64/python2.4/site-packages/osc/commandline.py", line 9, in ?
>>     from core import *
>>   File "/usr/lib64/python2.4/site-packages/osc/core.py", line 21, in ?
>>     import cElementTree as ET
>> ImportError: No module named cElementTree
>> sles10basic:/home # rpm -q osc build
>> osc-0.96-27.1
>> build-2007.06.13-6.2
> 
> Does your osc package show the same dependencies as here: ?
> 
>  % rpm -qpR osc-0.96-28.1.x86_64.rpm
> python-urlgrabber  
> python-elementtree  
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(CompressedFileNames) <= 3.0.4-1
> /usr/bin/python  
> rpmlib(PayloadIsBzip2) <= 3.0.5-1

looks the same for my installed package. When i try to udpate osc needs
python-elementtree (yast didn't tell me exactly that when installing first time, i now used rug
which made it clear)

Updating osc-0.96-27.1.x86_64[System packages] to osc-0.96-31.1.x86_64[20070626-051105]
There are no installable providers of python-elementtree for osc-0.96-31.1.x86_64[20070626-051105]

python-elementree is not available in SLES but in SLE SDK, maybe this should be mentioned somewhere
or the package could be linked to the tools repository from a location on the buildservice to
resolve this dependency.

thanks for your help.
Carsten

> 
> (I might have broken the dependencies yesterday, it may actually help if you
> download and try again)
> 
> Thanks,
> Peter
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iD8DBQFGgYZm6NfbfHY52TsRAsYiAJ95y/ZkO4coYh4iovmFJ+JR/JXCbACcDTmF
bQNgsyQc+vqg/Eo/DyUxZnY=
=sys9
-----END PGP SIGNATURE-----
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups