Mailinglist Archive: opensuse-buildservice (257 mails)

< Previous Next >
Re: [opensuse-buildservice] iChain switch succeeded :)
  • From: "Dr. Peter Poeml" <poeml@xxxxxxx>
  • Date: Fri, 13 Oct 2006 12:31:28 +0200
  • Message-id: <20061013103128.GZ1633@xxxxxxx>
On Fri, Oct 13, 2006 at 11:49:50AM +0200, Stefan Dirsch wrote:
> On Fri, Oct 13, 2006 at 10:36:30AM +0200, Stefan Dirsch wrote:
> > On Fri, Oct 13, 2006 at 10:28:08AM +0200, Adrian Schröter wrote:
> > > Am Friday 13 October 2006 10:06 schrieb Stefan Dirsch:
> > > > On Fri, Oct 13, 2006 at 09:45:35AM +0200, Stefan Dirsch wrote:
> > > > > On Thu, Oct 12, 2006 at 05:54:56PM +0200, Adrian Schröter wrote:
> > > > > > the build service now runs via iChain. This means that you need to use
> > > > > > your bugzilla/www.opensuse.org password from now on.
> > > > > >
> > > > > > The command line users need also to update the osc tool to version 0.9
> > > > > > to get access to it again.
> > > > >
> > > > > Unfortunately this doesnn't work for me, e.g.
> > > > >
> > > > > sndirsch@shannon:~/pkgs/openSUSE/games:action/xmoto> osc ci
> > > > > Error: can't get 'http://api.opensuse.org/source/games:action/xmoto'
> > > > > HTTP Error 400: Bad Request
> > > > >
> > > > > I'm using osc-0.9-5.1. Latest changelog entry.
> > > > >
> > > > > * Do Okt 12 2006 - poeml@xxxxxxx
> > > > > - update to 0.9 (r761):
> > > > > [...]
> > > > >
> > > > > user/pass in ~/.oscrc is set correctly.
> > > > >
> > > > > osc st/diff work. Anyone, who can reproduce this problem?
> > > >
> > > > Since adding/removing/editing files via the BS website works I think
> > > > this is an osc issue.
> > >
> > > Does it help to add
> > >
> > > scheme: https
> > >
> > > in ~/.oscrc below the [general] section ?
> >
> > Not at all. :-( My ~/.oscrc:

> > # use this API server
> > # (it needs a section [api.opensuse.org] with the credentials)
> > #apisrv = api.opensuse.org
> > scheme: https
> >
> > [api.opensuse.org]
> > user = sndirsch
> > pass = XXXXXXXXXXX
> >
> > > Peter, can you make https to be the default ?

Yes. I thought I already did so this morning, after I noticed that it no
longer worked (last night the testsuite ran fine) -- but being in a
hurry I did the change in the wrong place. Meanwhile I have corrected
it, and almost all new osc packages are built by now.

> > Looks like he already did, but this version doesn't work either for
> > me. :-(
>
> The problem is limited to machine 'shannon' and/or the current
> (python?) packages from STABLE.

Ah, thanks for finding that out. Probably a bug in python or
python-urlgrabber then.

Regards,
Peter
--
SUSE LINUX Products GmbH Bug, bogey, bugbear, bugaboo:
Research & Development A malevolent monster (not true?);
Some mischief microbic;
What makes someone phobic;
The work one does not want to do.
From: Chris Young (The Omnificent English Dictionary In Limerick Form)
< Previous Next >
Follow Ups