Mailinglist Archive: opensuse-buildservice (252 mails)

< Previous Next >
Re: [opensuse-buildservice] Help needed for Packaging
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 19 Sep 2006 09:04:31 +0200
  • Message-id: <200609190904.31702.adrian@xxxxxxx>
Am Tuesday 19 September 2006 09:02 schrieb Dominique Leuenberger:
> >>> Reply on 19-09-2006 10:00:36 <<<> Dne Tuesday 19 September 2006
>
> 08:54 Dominique Leuenberger napsal(a):
> > > Hi everybody,
> >
> > Hi Dominique
> >
> > > plib is noted in the BuildRequires tag and according the logfile
>
> plib
>
> > > 1.8.4 also got installed.
> > >
> > > Any ideas what I could miss there?
> >
> > try remove plib from BuildRequires and add plib-devel
> >
> > > Dominique
> >
> > Pavel
>
> I checked at home on my workstation for plib packages; plib-devel did
> not exist, that's why I added plib.
>
> I tried to add plib-devel on the BuildService, and it failed with:
> expansion error nothing provides plib-devel

Right, there is no plib-devel, the plib package contains all needed header and
lib files.

You should do a local build with "osc build ..." on your workstation.
Afterwards you can do a "chroot /$OSC_ROOT" and look inside what wents wrong
inside.

A first look on our plib spec file tells me that there are most likely missing
requires for freeglut-devel. IMHO the plib package should also get a -devel
package in future. The libdrm-devel in BuildRequires looks also obsolete.

Marian, do you plan this ?

--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >